Upgraded to V1.62 - but Arc set to v0

Hi Guys,

new to the SA30 - wanted to install the latest firmware and completed via USB method. after upgrade and factory reset, per instructions, the system shows the following:

Host V1.62
NET V1027
ARC V0.0
ARC Rx V0.0.0

Any ideas how to resolve the loss of Arc firmware? i have tried the process again with Ethernet and hdmi cable removed- no change…


1 Like

You might want to try upgrading via the web page. Look in your SA 30 Network settings, network info, IP address. Open that address in your web browser. In the browser go to device settings, Reboot in update mode, follow the directions. I would download the latest published firmware again, and save it to a handy spot. You will point the browser to the image.swu and once it starts just leave it alone as it might take 10 min or longer.


Hi Tim, welcome to the forum!

There is another thread (Weird user guidance during OTA firmware upgrade) which might be related. This post reports after performing a reset the update was successful (How to do a full reset and reload of firmware - #17 by Dirk). Hope this helps.

I had nearly the same problem after update to V1.62. ARC did still show version 1.6 and not 1.7. Tried to update again but it didn’t help. I contacted ARCAM support and they gave advise how to solve the problem (by access to “hidden menues”) and it did. But, your problem is not exactly the same so I think you should contact ARCAM support for advice that eventually will solve your problem too.

Hi Guys, thanks for the ideas. I reformatted the usb stick, new firmware download and started again but with the same result, I then tried the web interface and alas the same result. I have emailed Arcam for support but curious if anyone else has tried the power up and service button reboot option mentioned in one of the other posts?


Hi Tim, you need to run a special ARC recovery option, and if that doesn’t work you will need to return it to us so we can reprogram it for you. I will send you instructions.


Hi arcam_paul,

The instructions worked. Many thanks for your help.



Hello Paul, my name is Frank and i’m from germany so please excuse my poor english. I got the same problem as Tim. Since the last update my arc dropped to version 0.0 and it didn’t work. Hope you can help me too.
Sincerely Frank

Hi Frank

Don’t apologise, your English is fine :slight_smile:

I’ll send you a private message.

Hi @arcam_paul
I think these recovery instructions could help me too since I am experiencing some issues with the 1027 firmware build. My network settings seems to be lost as the unit displays the following I.P : and net V0.
Moreover I am unable to reinstall the firmware via USB and reset the net (the unit freezes).
There is nothing I can do at this point.

Thank you for your help

Hi @Johnduff

I’ve sent you a PM.

1 Like

Hi Paul,

same here, after update to 1.72 my arcam SA30 shows:
ARC V0.0
ARC Rx V0.0.0

1 Like

Hi, I have the same problem and I dont know hon to do a ARC recovery. Please help.

Best regards, Fredrik Nordstrom

Hi Paul, I dont use ARC at the moment but may do in future. After updating to the latest version of the software all updates seemed to go well but ARC is showing as V0.0. Any chance you could send me the instructions? Many thanks

I have exactly the same issue after a “successful” upgrade Arc version 0.0 arc rx 0.0.0. Do i need to return the unit?

Dear arcam paul.
From Russia with love))
I have the same problems as all users under this post. ARC ver. v0.0 etc.

Could you please helped me. Thank you in advance.

Hello Paul, my name is Thomas and i’m from Poland. I got the same problem as Tim. Since the last update my arc dropped to version 0.0 and it didn’t work. Hope you can help me too.

Hi neighbor :wink:
Please contact Arcam support directly. It was mentioned in the past, that it’s preferred way to report this issue. They can also provide you with instructions, but at the same time they can keep track on how many users have this issue.
Just send email to arcam.support@harman.com

hi i just sent them a message. Greetings from Poland

Same here-

Tried to go recovery mode, using a usb memory with image.swu on it, but the display showed net updating and then failed, different from what the recovery manual says so.

Sent emails to both Arcam supprt and Harman luxury support.

Waiting for their answers.

So sad that although the amp works perfectly and sounds very good, I cannot connect it with mh TV as it’s supposed to do.