Stuck on "Net Updating"

Hi everyone, I am new to the forum. I am having a problem with the newest update on my SA30.

On Tuesday 22 March 2022 I switched my Arcam SA30 on and “Net updating” appeared (connection was through wifi). I left it on for 24 hours but the display didn’t change. I then switched off and restarted, the same message “Net updating” appeared and didn’t go away after several hours. I then tried to use a USB stick with (only) the image V1542.swu file on it but this also didn’t work. I then tried pushing the service button on the back of the SA30 for 30 s while switching the device on, with the USB stick with the file inserted, but after a few seconds “Net Updating” again appeared and stayed for several hours before I switched the SA30 off. I then tried a cable connection, but the same thing happens: “Net Updating” remains. No status bar ever appeared. Today I formatted another USB stick (fat32), copied the file onto it: image.swu (renamed to this) and tried again, but no luck: I am still staring at “Net Updating” on the display and can’t operate the SA30 at all.

Any suggestions of how this problem could be resolved would be very welcome!

1 Like

I’ve messaged you privately.

Hi there!
I’ve got exactly the same issue with mine SA30 on this wednesday!
Just turned it on and now it’s totally bricked with the “Net updating” message :frowning:

Hi Polonium

After checking out the forum and chatting with paulguk, the following procedure worked for me:

  1. Switch SA30 off and unplug the speaker cables
  2. Freshly format a USB stick (FAT32) on a Windows PC
  3. download the newest Firmware version, unzip and rename the .swu file to: image.swu
  4. Copy only this file onto the USB stick
  5. Switch off the SA30 and insert the USB stick
  6. Press the service button on the back in and hold it like that
  7. Power on the SA30 while holding the service button pressed for 60 s
  8. Release service button
  9. Screen should show “net updating”. just leave it alone for ca. 10 min (perhaps longer)
  10. Screen switched to show “ROOT UPnP”
  11. Perform Net Reset and System Reset
  12. et Voilä! everything is up and working

This is actually described in a post by paulguk from 2021:

I hope this works for you too.


Hi Roelene! This worked out! I think the trick was in filename and lack of feedback from the amp that it actually started reprogramming.

When I left the amp turned on after step 8 and went to kitchen to cook the breakfast,
the amp rebooted and started playing smth on extremely high volume and then turned off in a couple of seconds (possibly after overload protection was activated).

So I think that step 0 of the manual should be “unplug the speaker cables

Hi Polonium
Glad it worked out for you.
Good point… edited the post with point 0.: unplug speakers :slight_smile:

I wonder if the naming of the swu file might be an issue. Previous firmware updates have been called image.swu where as this one also has the version number in the title.

Renaming the file might be the solution to problems people are having.

Hello, renaming alone does not work. I already tried that and had the same problem. I have not tried the steps on this post since I reverted back to old firmware, disabled OTA updates to have the device working again like that. I was lucky to have an old firmware on my laptop since there is no way to download those form the web .
I think I won’t update, I don’t feel like taking all the hassle of disconnecting, and also because during one of the attempts It seemed that it finally updated to newest firmware (I was able to see the new options on the menu and see the new version on the web interface) and the new version caused constant disconnects from the wifi so even though I of course would like to have latest firmware, the new firmware was not tested properly on all devices, I guess there are some different hardware variations and mine is negatively affected by the new firmware.

Thanks anyway for showing the steps .

I hope someone from ARCAM read this and come with a solution to the device losing wifi . I have written to ARCAM support with all the details but no response from them .

Same here. Drives me nuts. Did a reset, but does not make any difference. Starts with the fake Net Upgrading, but since it has no connection with my internet anymore (can’t fix that and the manual does not tell me how to do it), it does not even have a serial number anymore… retailer can’t help. Harman auto-replyed they will answer within 7 days….

Is there also a solution when one does not have a Windows computer (MacBook) nor usb-stick?

Turn it off, back on.
Before it gets into net updating disable OTA updates that is part of Settings. Try that and let me know since I have other suggestions.

Disable OTA does not make a difference. ‘Service’ button on the back makes no difference. It just keeps saying ‘Net Updating’ :scream:

I had the same issue since last Thursday. It’s bizarre how many people have reported this in the last few days.

I created an account here just to let you know that your solution has fixed the problem for me as well. Thank you very much!

In case it helps anyone else; my unit reacted slightly differently. After step 8 it showed something along the lines of “Press menu for system options” for some 30 seconds, but I just let it be. It went back to “Net updating” and after another 30 seconds, to my surprise, showed “Update complete”. I left it for 10 minutes but it just sat there, so I turned the unit off and on, after which it was stuck on the boot screen for perhaps 5 minutes before rebooting by itself - and it was back to working again! Do note that it is indeed important to rename the update file to “image.swu”, the filename as it is in the zip file won’t work.

Reluctantly I decided to disconnect the amp and to try the service button trick which location is not in the manual and requieres a pen, so I had to un mount the amp.
It started “net updating” and after 30 minutes It still showed the message. I risked it and turned it off once more.
When turned back on I was able to connect via wireless to the webpage and noticed it was upgraded to version
Device version: 0.100.1542.0xff21fd0
So far no issues , I am listening while writing this.
Will post update in a few days

For completeness’ sake, I too had the idea of disabling OTA updates before, but it didn’t make a difference either. I’m afraid your best bet would be to get hold of a USB stick with the firmware file on it. Don’t forget to rename it to “image.swu”! :crossed_fingers:

@Katja are you able to connect from your phone to the webpage ? How long does it takes to show net updating after you turn on the amp?
If you manage to connect to the amp from a web browser try an optic that says “Boot in update mode” or something . Wait a bit …. Minutes … and the you will be able to upload the firmware and cross your fingers

I don’t own a computer with USB nor an USB-stick🤷‍♀️ I thought that was something of the ‘90’s

I don’t know which webpage you mean I should try to connect to? Would you please be so kind to tell me? The amp starts with Net upgrading, at least pretending to, immediately. There is no way to stop or pass it.

It’s not bricket, only switched to update mode.
Just waiting for swu upload from browser.

Go to menu, then network settings, then network info. Take note of the IP address
Then open that IP address in your phone browser and see
Is goin to be something like

So far new version has some issues so I will consider reverting back to old version. Where can I find old versions of firmware??? The old version I have is kind of old .

My current issues:
Music stop playing and amp becomes undiscoverable on network . I use AirPlay 2
Net Reset function never competes