SA30 build 1027, version 1.62

Hi madfiddler, there is more information available in on the the threads in the beta section. I’ll ask if it is possible to release this information to the general public. Below you’ll find an excerpt.

Changes from v1.51/969

This build addresses the following issues:

  • Various Roon fixes
  • CEC does not wake the SA30
  • Debug logging is off by default

NOTE If you previously had 1.51/969 installed, you will need to do a System and Net reset to turn debugging off.

CEC Power On

In order for the SA30 to wake when the TV sends CEC power on commands, two options must be set:

  • Audio Settings > TV Power > Auto
  • Network Settings > Network Standby > On

Known Issues


We have become aware of an issue resulting in the SA30 reverting to FLAC playback instead of decoded MQA. We believe this is an issue from the streaming service itself, but we are still investigating. This is currently affecting all products, regardless of software version.

ARC dropouts

Dropouts have not been resolved in this build. The engineering team know of this issue and are working towards resolution.

ARC/CEC volume commands require more presses when Maximum Vol in use

Using the TV remote to control the SA30 may require more presses when maximum volume has been set. To avoid this, use the SA30’s supplied remote control for volume.

So far i think that ARC interruptions is off ,at least i haven’t notice any so far. :+1: :v:
But i notice something else .
Changing Sources From CD to PVR (pvr is my tuner) it freezes and it takes ~20 second to play music. Also it is not responding the remote.


After the update it still show ”ARC V1.6”, not ”ARC V1.7” as in the release notes. The other ones are correct, Host version V 1.62, Net V 1027 and ARC Rx V 1.0.0. Anyone experienced this?

I’ve just tried this, and going from CD to PVR is instant. Also, I can change inputs without pressing AMP each time.

I am starting from PVR changing to CD and then back to PVR and freeze.
On both sources I have enable Direct but even if I disable it still the same.

I’ve just tried it with Direct ON and get the same result as you! A delay. With Direct OFF there’s no problem.

i reinstall now the firmware from USB with Factory defaults and we will see…

Distortion with MQA through Roon Ready :woozy_face:

Anyone have an issue with the remote not working anymore? Lights up, can still control the TV, but cannot change source or volume of amp with the original remote.

Did you search the issue section on the keyword remote already? There are quit some (usefull) topics about the Arcam remote control, e.g. Remote control doesn't switch on SA30, ref#106 (caused by dead batteries).

Yes I have even changed the batteries to completely new ones and the issue persists. The TV responds but the amp ignores the remote entirely.

Try to change System Code from the Menu . You can navigate from the buttons on the Amp.


Thank you @iarvanit !!! That was it. I must have changed that by accident when I was fiddling around in the menu when the update took ages to take. :hugs:

1 Like

Does anyone have the issue that the amp sometimes just switches to other inputs without pressing any buttons?
Mine switches from NET to Phono and back sometimes withouth any buttonpressing. Feels like magic, except it’s not as fun

I have not seen this. Is there other gear in the room that might be causing interference? Maybe you could turn off everything else and leave the Arcam running for hours and see if it happens. I will watch for it! Thanks for letting us know.


unfortunately i notice some interruptions from ARC .
No as much as before but it still here.

ARC dropouts are not fixed in this build, as mentioned in the release note of post 10:

ARC dropouts

Dropouts have not been resolved in this build. The engineering team know of this issue and are working towards resolution.

Arc sound drops is the last major bug for which I hope a resolution in the coming weeks ! After that I’ll finally start enjoying my amplifier to its full extend (as it should have been from day one) and play with Dirac :slight_smile:

Yes, I noticed this immediately after the unsollicited upgrade to v1027 (ota upgr was disabled). Playing from Musiclife or Qobuz app it stopped playing and input switched to CD.
This happened several times.

How do you know or how to get system to show Roon Certified?