SA30 build 1027, version 1.62

I am starting from PVR changing to CD and then back to PVR and freeze.
On both sources I have enable Direct but even if I disable it still the same.

I’ve just tried it with Direct ON and get the same result as you! A delay. With Direct OFF there’s no problem.

i reinstall now the firmware from USB with Factory defaults and we will see…

Distortion with MQA through Roon Ready :woozy_face:

Anyone have an issue with the remote not working anymore? Lights up, can still control the TV, but cannot change source or volume of amp with the original remote.

Did you search the issue section on the keyword remote already? There are quit some (usefull) topics about the Arcam remote control, e.g. Remote control doesn't switch on SA30, ref#106 (caused by dead batteries).

Yes I have even changed the batteries to completely new ones and the issue persists. The TV responds but the amp ignores the remote entirely.

Try to change System Code from the Menu . You can navigate from the buttons on the Amp.

2 Likes

Thank you @iarvanit !!! That was it. I must have changed that by accident when I was fiddling around in the menu when the update took ages to take. :hugs:

1 Like

Does anyone have the issue that the amp sometimes just switches to other inputs without pressing any buttons?
Mine switches from NET to Phono and back sometimes withouth any buttonpressing. Feels like magic, except it’s not as fun

I have not seen this. Is there other gear in the room that might be causing interference? Maybe you could turn off everything else and leave the Arcam running for hours and see if it happens. I will watch for it! Thanks for letting us know.

Ken

unfortunately i notice some interruptions from ARC .
No as much as before but it still here.

ARC dropouts are not fixed in this build, as mentioned in the release note of post 10:

ARC dropouts

Dropouts have not been resolved in this build. The engineering team know of this issue and are working towards resolution.

Arc sound drops is the last major bug for which I hope a resolution in the coming weeks ! After that I’ll finally start enjoying my amplifier to its full extend (as it should have been from day one) and play with Dirac :slight_smile:

Yes, I noticed this immediately after the unsollicited upgrade to v1027 (ota upgr was disabled). Playing from Musiclife or Qobuz app it stopped playing and input switched to CD.
This happened several times.

How do you know or how to get system to show Roon Certified?

Just restart the Roon Core

Distortion is not completely gone. Compared to build 867 it is much less frequent en less loud.
Today I was playing from Qobuz (using the Qobuz app) for several hours and noticed it twice while playing 96Khz tracks. Last one was The Torture never stops from Zappa. In this context the title describes my mood now…

1 Like

Roon used to indicate in the signal path when Dirac was being used by the SA 30. This indication in Roon disappeared a month or so ago. I thought it might reappear after the SA 30 became certified, but it has not. Is this something that is no longer supported by Roon or Arcam?

Is there any update from ARCAM about the distortion or are we going to return the units to the dealers?

Thanks

Jaro