Cannot install software update as device does not go into Update Mode

I am trying to install the latest software update via the Web GUI by selecting 'Reboot Device to the Update Mode’. However, all I see is a message saying to wait until the device reboots into update mode. This is on the screen for about 30 seconds then the web page just goes to the Main Page. So for some reason the device did not go into Update Mode. I do not get any prompt to provide the location of the software. Has anyone else had this problem? I have tried via my iMac and via my windows laptop. I have used Chrome, Firefox and Safari but all give the same lack of result.

Can you install in other ways such as putting the file onto a USB pen and plugging it into the back.

Please go into the menu and do (separately) a system AND net reset and retry the update:

I had a comment from the official Arcam support that using Update Mode is the only way to update from the initial release software as is installed on my unit.

Thanks for the suggestion. I performed the net reset followed by a system reset. I then tried via my iMac with Chrome and Safari but still no result.

As a last try, please go to the web page, do a factory reset from the device settings (asusming you are on a wired network!) and retrry the reboot in update mode. If that doesn’t work, customer support can guide you through the USB update procedure.

1 Like

Looking good but taking its time. I saw the message “SWUPDATE successful !” but now appear to be stuck with “Please wait for the device to reboot to the application, webpage will refresh automatically…”. It has been over 20 minutes now and when I check the machine the red light is on, the LED is off, and there is a regular clicking noise coming from inside…

1 Like

Looks as if it needs to go back to the factory. Just clicking away for 7 hours until I decided to turn it off. When restarted the same clicking with the display blank and the LED light red.

I will let the Arcam Support know and will contact the dealer. Thanks for your help, we nearly succeeded.

Hello! I got the same problem while updating the firmware. The device rebooted and does not turn on anymore, clicks are heard when turned on. How did you solve it?

Arcam support said the main micro of the unit is stuck in a boot loop. The unit needed to go back to the factory for the micro to be connected to a special jig and flashed with software.

This was done very quickly and efficiently. The repair note says “corrupt boot loader s/w - reloaded with external programmer”.

1 Like

Thanks a lot! At least one person explained what happened to the device. Apparently not fix this on your own?

If Arcam support request it to be returned I doubt there is much chance for me to have been able to fix it on my own. I think I should have made sure the Standby timing was not set at the default 20 minutes before starting such a large software upgrade.

And what firmware do you currently have installed on the amplifier?

Did you get ur issue resolved?

Yes, but it had to be sent back to Arcam for them to re-initialise.

It is scary. It should just update. So what is the full working procedure to have your unit upgraded to the newest version? I tried to check for new update on the web page it wasn’t even able to notice there was a new update available…