Streaming services with SA30

Hello, My Arcam SA 30 has been out of Tidal connect, MusicLife, Spotify for about a year now. It’s like it connects, but for a few seconds. I can only listen them through Airplay. Many people complain about the bad performance, but for me it does not work at all. I haven’t found a clear answer in the forums. Help, please !

Are you using WiFi or Ethernet?

I run Roon about 10 to 12 hours a day over Ethernet without ever really having any issues (ok sometimes it doesn’t recover from sleep in a few seconds). I also occasionally use Chromecast and Tidal Connect as well with no issues (besides Tidal sometimes doesn’t release the device, but that’s usually my son).

Maybe try resetting the network settings first and if that doesn’t work, then try a factory reset.

If WiFi maybe your device is not getting a good enough signal. When using Airplay 2 you are often only getting 256KB AC3 which is low bandwidth compared to 16/44 CD quality that you are probably getting from Tidal. You could try reducing your Tidal settings and see how that goes.

So what changed a year ago?

Tidal connect,Spotify,MusicLife direct no longer works. First I have to turn on AirPlay and then specify Arcam SA30.

2024-01-29, pr, 02:48 madfiddler via The unofficial Arcam SA30 community <notifications@arcam.discoursemail.com> rašė:

The reason I asked the question is because you said it worked up to a year ago, so what changed at that point in time? If you say nothing at all, no change in network in your apps etc then fair enough but I would look to those things first. Tidal,Connect, Spotify and musiclife all work in quite different ways, which is making me think network issue first. Airplay will work since it’s casting direct to SA30, that’s not across yoru local network like the other things will be.

What does network info on your SA30 say? Does it have an IP address and can you connect to that via the web client from a browser?

The network is fine. I think there’s something wrong with the soft. I will do a factory reset.

2024-01-30, an, 02:52 madfiddler via The unofficial Arcam SA30 community <notifications@arcam.discoursemail.com> rašė:

Clearly it’s not otherwise it would work :wink:

I bought my SA30 two months ago. I have been streaming with Tidal and using the Tidal Connect feature from within the Tidal app. No issues. A few weeks later I downloaded Music Life for Arcam so I could stream internet radio, which shows up as “airable radio” on the SA30. This needs WiFi to work. The SA30 manual states that plugging in a network cable will override WiFi, WiFi does not work with an Ethernet cable plugged in. This, from page 14 of the manual:

"In order to use the AirPlay and Chromecast built-in
functionality of the SA30 you will need to connect it to
your home network via a wireless or wired connection.

The following sections detail how to do this.
Note: Before attempting to setup a wireless connection
ensure the supplied wireless antenna is fitted to the
antenna socket on the rear of the SA30.

Note: When the wired connection is used the wireless
connection is automatically disabled.

So to get what should be the best quality I connect the Ethernet cable. When I want basic background music I unplug the network cable and stream internet radio stations. This has all been fine until last night.

Now when I plug in the network cable “Tidal Connect” does not connect to the SA30. Sometimes Chromcast will show up and connect but for the most part I need to unplug the Ethernet cable and Tidal Connect will then work via WiFi.

One thing I notice, and I am not sure if this matters or if it was happening before, is that the little green LED right beside the Ethernet port flickers. Should it flicker or should it be on steady? If it should be on steady does this suggest there is an issue with the port or the amp?

If I look at the online devices listed in my app for my Orbi WiFi router it shows the amp connected by Ethernet as “SA30 - Google.Chromecast” Not being tech savvy to the highest degree, does this mean for some reason it will only work using Chromecast now for some reason?
Just mentioning this to provide as much information as I can gather.

Any advice would be greatly appreciate .

To your very last question, no it doesn’t mean that. It’s just a name, you could call it “Maureen” :slightly_smiling_face: …. Will have to have a think about the rest!

So first of all playing internet radio via MusicLife does not require Wi-Fi, it requires an internet connection that could be wi-fi or via Ethernet cable to your router.

You should not therefore have to disconnect the Ethernet cable to play internet radio, that makes no sense,

The light flashing on the Ethernet port are flashing when data is transferred, you’ll see the same in the back of the router.

So your issue is that Tidal Connect has stopped working over Ethernet cable connection to your router/network, is that right?

Generally speaking a cabled connection should be more stable, but if you have a strong Wi-Fi signal then you shouldn’t worry about it, just use Wi-fi. Then you don’t have an issue at all do you?

As for why Tidal Connect stopped working when using the Ethernet cable, someth8ng else must have changed on your amp or network. In the network info on the amp, when the cable is plugged in is it showing an IP address or 0.0.0.0? What else has changed recently? If you really feel a need to fix this and not just use wi-fi then I’d suggest equivalent of “turn it on and off again”, I.e. a network reset on the amp

HTH

2 Likes

Thank you all for your advice. MusicLife, Tidal connect didn’t work for me. Only with Airplay. I did a system reset several times with no results. Even Dirac profiles remained. Unplugging the mains helped. I use Ethernet and apps on Iphone.

2024-02-17, št, 23:02 madfiddler via The unofficial Arcam SA30 community <notifications@arcam.discoursemail.com> rašė:

System reset doesn’t reset network module, which server all network functions and Dirac.
You need NET reset. After that you will need to configure everything from scratch (Dirac profiles, Chromecast etc.). For Dirac, if you have saved the projects, it’s just matter of uploading fiters to the amp, no measurements needed.
Do you have other ethernet devices at home? Do they have any issues? Have you tried different ethernet cables? Maybe there’s something wrong with them. Cables can cause many strange issues with network connection.
I don’t suppose you have some fancy router at home with VLAN’s etc, as that could also cause some issues if misconfigured.

2 Likes