Tidal connect discontinued with SA30?

Am I to believe that Tidal connect no longer works with the SA30?

I have to say I was absolutely delighted to learn that I could use the Tidal interface with the streaming software of the SA30. In addition to all the benefits of using the Tidal platform as the primary interface as opposed to a ‘shadow interface’ such as mconnect or musiclife to access my Tidal library, I immediately connected and enjoyed the speed, the slickness and what I thought was a degree more clarity.

There were after two or three months some glitches in playback, but now it has completely disappeared and Arcam (SA30) is now not even listed as one of Tidal’s partners. Is Tidal in the process of fixing bugs or have they permanently ceased cooperation with Arcam?

Any answers much appreciated…

Mark

I am also experiencing problems with Tidal Connect. Specifically, it stops working. The only way to fix the problem is to uninstall Tidal from my mobile phone and reinstall it from Play Store. However, after a few days same problem reappears and have to repeat the same all over again.

Thanks a lot. I’ll give that a go. I’m hoping that Arcam and Tidal are working out a more long-term solution, though.

Cheers,

I don’t generally use Tidal Connect, but my Wife and Son do and I have not heard any complaints.
As the SA30 supports Chromecast, which works perfectly on Android, does it support Chromecast on iOS as well?

Hi, but when you reinstall the app, Tidal connect working?

Yes, but only for a few days, then it stops and need to re install the application again.

I’ve reinstalled the Tidal app and connected via Tidal Connect, and all good so far. Will see how long it lasts.

Cheers,

I’ve experienced problems with Tidal Connect recently as well. Connects, but stops… Of course I can use other methods, but I’m very happy with the speed and sound with Tidal Connect. Last time it worked again… it isn’t stable anyway, and that’s a shame

I had the same problem. On tidal connect it was showing my speakers but didn’t connect. I went through the process of adding the speakers through the Google home app and still no joy. It was only after frustration that I deleted the Tidal app and re-installed that it worked. It now seems stable and I need to go through the hassle of adding Dirac. But this time the sound stage seems to be missing something. Familiar records sound subtlety muted.