SA30 reboots while playing music

This is the first time I experienced a reboot with build 1027. The next scenario probably will not reproduce. If other users experience reboots then please comment. If anyone has tips on how to troubleshoot this issue then please reply.

Scenario
Perform the following steps:

  1. switch on Arcam SA30 version 1.62 build 1027 is used
  2. start Arcam Music Life iOS app, build 4101 is used
  3. play some music albums through upnp and listen to radio streams

Actual result
SA30 reboots while playing music.

Expected result
No reboot should happen.

This happened to me today for the first time. Half an hour and it reboots, another halv hour and new reboot. On my way to third reboot, we’ll see. I only play through upnp today, from a MinimServer.

1 Like

Please check for pattern. I’ve seen this on v867, when using QNAP built-in UPNP server and MusicLife app (Android). In my case reboot was always happening when switching between 2 particular tracks/files from one album. Haven’t tested on v1027.
So try to note song that was played and re-create using same song/playlist later.

This issue might be related to the following 2 issues. I reported the following similar issues on build 867 (not listed here) to Arcam:

  1. SA30 reboots after Upnp playback through remote control ref#114
    This issue was reproducible 100%. If the path was too long then the SA30 rebooted. E.g. in my case if I renamed the last part of the path (And The Beat Goes On! 20 Years Of Hardcore) into something short e.g. 1 then no reboot occurred.

  2. SA30 random reboots ref#104
    This issue was hard to reproduce, in the end Arcam was able to repro it. After 2-3 hours of listening to lossless flac files the SA30 rebooted.

After some investigation Arcam though both issues had the same root cause. Below an excerpt:

Basically the two issues have the same root we think. We expect track metadata (title, artist, album etc) to be truncated to 40 characters. ref#114 is a little trickier, as even if you rename the file it’s still crashing. Anyway - for this particularly issue, the network module is sending full strings to the host, which is expecting certain bits of information to be in certain places.

In the above case, the album name is “Live at Tomorrowland 2020 Around The World (The Digital Festival) (2020)” which means the album name is overflowing into other memory spaces and corrupting memory.

ref#114 was easier, as you could actually reproduce when playing straight from a USB drive. As soon as you attempted to play it it would crash. Whereas here, you’re essentially waiting for memory to get corrupted

That would make sense. The two fixes for those problems were not in 1027. IIRC 1027 was 867 with Roon certification fixes. I’m not sure off the top of my head whether any other fixes were pulled in.

I could be wrong though, as I thought these fixes were applied in the host (1.62) not Net.

I’m not sure what got fixed in which build. I found in the comments of ref#104:

V1.51/969 should fix this

From the release notes of build 1027:

3955 - Browsing UPnP folder with long name crashes SA30

1 Like

Thanks for checking - you found that quicker than I did.

That does imply that those fixes are in there. I’ll see if QA can reproduce.

1 Like

I was aware that certain characters in the folder structure would crash UPNP. I had a folder called Bob Marley + The Wailers and it didn’t like the +. It’s ok if it’s in the track meta data but not if it’s in the actual folder structure. There were other characters as well that crashed it.

Unfortunately I still get reboots on 1.62, 1027. It may well be the file names. It happens on Siegfried with file names like “11 Act 1, Scene 2_ ‘Hier sitz’ ich am Herd und setze mein Haupt’ (Wanderer).m4a”. However, when played the beginning of each track it works but listening to a whole Act does not work. Exactly where, and if the same place, I have not tried to work out yet.

Sounds very similar what I’ve experienced with the ealier mentioned issue SA30 random reboots ref#104. Sometimes after a whole album it didn’t reboot, sometimes after the 4rd track of the same album it rebooted. This issue doesn’t reproduce very well, it may be related to the earlier mentioned issues, maybe the root cause hasn’t been fixed yet.

Until now I experienced one reboot with build 1027.

@arcam_paul were you or one of your colleges albe to reproduce this issue?

I had a reboot yesterday. I was testing the optical link between TV and SA30 and noticed that I couldn’t adjust the volume from the app. I went to the amplifier, touched the volume control and it rebooted.,

Is this still crashing for you?

This file name length would have caused the issue of #114, which I thougt was fixed. Would it be possible for you to direct message me with a link to this folder of files, and I can try and reproduce on my unit here? I have debug logging tools that you dont have access to.

I haven’t heard from anyone able to reproduce this no. I’m currently on the alpha build of the next update which has significant changes. As I can’t reproduce I can’t say with certainty whether I’m just not hitting the scenario, or if the update fixes this issue. If there’s a fairly reliable way to reproduce it (possibly how Arnjo reports above) then I can try that instead.

1 Like

Hopefully this link works for accessing Siegfried http://192.168.1.157:8080/share.cgi?ssid=0ACqE7w

Sadly that’s an internal network address.

I’d ensure this is sent as a private message to me though as I’m not sure about any legal complications about sharing this piece.

Ok, let us try dropbox then

download link removed

/Arne

1 Like

Issue SA30 random reboots #104 is definitely not fixed. Today my SA30 rebooted while playing album Roxette Hits! A Collection Of Their 20 Greatest Songs! (2006). This album was part of the this bug report.

Since 1.62 update, SA30 randomly reboots on track change or source change
I will investigate and provide the full track name with entire path and the ID3 / APE tags (whichever are in use).
I have a copy of MP3Tag so can run some AvB comparisons with long and short names if that might help.
However, it also appears to reboot when bit rate of source changes (i.e. I create a playlist with 44.1kHz CD FLAC and 96/24 FLAC and it will reboot when the bit rate changes). That might be conflated with the change in tag length, but might be a different issue.