SA30 not showing in Google Home

Hi, I recently bought an Arcam SA30, but so far I have not been able to make it appear on Google Home.

I have upgraded to latest firmware version (v867) and I have done system and net reset. I have configured wireless network with webclient and the device appears on MusicLife app.

But I have not been able to make it appear as a cast device.

Any ideas or suggestions?


Hi Thanasis, welcome to the forum! Did you already have a look at the following topic?

Hi jvs1,

Yes, I have seen this thread, but my problem is that the ARCAM SA30 is not visible in Google Home to perform the steps in the thread. Google Home cannot find SA30 when it searches for cast devices.

Just to isolate the problem, did you try with a wired SA30?

Yes, same behavior. Also my Google Home app sees normally other cast devices that I have, like my Smart TV.

Did you try the Google Home app on iOS and Android? Are you able to stream music from your nas with the MusicLife app?

I do not have an iOS device, however I have tried Google Home on my phone and a tablet (both Android) and none of them was able to see the SA30. I am able to stream music from my phone with the MusicLife app (although MusicLife recognizes SA30 as UPnP renderer and not as cast device).
I also would like to ask you to tell me how did you setup your wireless connection for the SA30. The only way I found to do this was to connect with wire and configure the wireless interface from the webclient that SA30 has, using my PC.
By the way, there is no mention of this webclient in the SA30 Handbook. I found about it by googling.

Well, usually it’s actually Google Home is used to Connect SA30 to wireless. When configuring Google cast device, it’s automatically connected to your WLAN.
It’s weird issue. To be honest I think you’re the first person having such problem.
Try to re-flash the firmware and perform another reset. To re-flash download latest FW from Arcam website and upload it using web client.
BTW- do you have any other Google cast devices working at home?

Yes, I have a Smart TV and this is visible in the Google Home app, works perfectly.
One question: The first time you connected the SA30 to Google Home did you had it connected in the network by wire?
Also, I have the latest firmware installed and did system and net reset.

I cannot tell how to connect the SA30 wireless because I prefer a wired connection. If you send music data through a wireless connection then assure the quality of the wireless connection is good, a poor quality wireless connection is prone to audio drop outs.

I always have the SA30 wired. At the time I experimented with Google Cast it worked. I don’t use Google Cast with the 867 build.

This is indeed weird. As Felix suggested please reinstall the SA30 firmware, I would recommend the USB method. Have a look at the following topic how to install the firmware. Don’t forget to factory reset and reboot the SA30. Reinstall and try Google Home with SA30 wired.

This might happen if you have a heavily locked down router, unauthorized ports etc…
You can do a lot at that level to secure and filter devices and it might be one explanation.
Just a hint…

@Thanasis on 867 I only tried wireless connection, and actually used Google Home app to configure Google Cast on SA30, but also to connect it to my WLAN. Worked perfectly fine.
Used Wired connection with previous firmwares, and it was also OK.

I downloaded the logs from the webclient and found these lines in log-nSDK:

20201201 20:28:57.502 [2605.2649] INFO WatchDog: Monitor: addProcess: id=2706, name=castControlApp
20201201 20:28:57.578 [2605.2649] INFO GoogleCast: Audio config file /etc/cast_audio.json exists and has valid json format
20201201 20:28:57.611 [2605.2709] INFO GoogleCast: Enter void CastWifi::on_networkInfo_changed(const NsdkValue&):
20201201 20:28:57.667 [2605.2649] INFO GoogleCast: Credentials are not available, retrieving…
20201201 20:28:57.774 [2605.2649] ERROR GoogleCast: Chain generator failed with exit code: 1
20201201 20:28:57.775 [2605.2649] INFO GoogleCast: Enter void GoogleCast::on_credentialsRetrieveFinished(bool): success: 0

I am not sure what they mean, though… I will send them to Arcam support.

For now my workaround with casting, is to cast to my TV and send the sound with HDMI ARC to the SA30…

Stupid question - is your phone (or whatever device you’re using to configure Google cast) connected to the same network SA30 is connected?
What encryption is your WLAN using?
And if by any chance you have “AP isolation” option enabled in wireless settings of the router?

1 Like

Did you have a look at the log-cast_shell log file? This log file is related to the Google Cast functionality. Look for the words FATAL or ERROR. The severity fatal is used when something is definitely wrong, this log entry should be a very useful lead for support. I believe not every message with severity error is an user error, it may be used to start alternative flow, e.g. if a settings file cannot be read then some other (factory) defaults may be used.

Having a look in the log files is looking for a needle in a haystack, I’m not sure it will help in finding the answers you’re looking for. On the other end it is the only detailed information the device generates. It depends on if the SA30 detects your (error) situation, next is should be logged properly. I think you should sent support the entire log archive.

@Felix: Yes, it is in the same network. Encryption according to the router is WPA/WPA2-PSK-TKIP/AES. I have not enabled AP isolation. Also, as I have wrote I have no problem in casting to my TV, which is in the same network.

@jvs1: I did not go through all the logs, however I have sent everything to support (whole .gz archive that the device generated).

After sending the log files to Arcam support this is the reply that I got:

“Thank you for confirming. I’ve not seen this happen before… I wonder if perhaps the network module in this unit somehow was corrupted when being flashed with its google certification. It would be worth contacting your dealer to see if they have any luck when investigating it. If not, it might need to come in for a re-flash.”

Maybe my unit is faulty…

Just to eliminate any aspect related to your environment and / or its settings. Is it possible to temporary move your SA30 and to set up Google Home at your friends place? It might be less hassle compared to shipping the SA30 and to avoid any risk of damage (or even worse loss or theft) during the shipment.

I have the exact same problem, and it has been like this since I got the SA30 in July 2020. It was a pain setting up the Home Network the first time, but somehow magically the SA30 suddenly showed up from out of nowhere despite me not doing anything right then, and after hours of trying to figure it out.

What also happens is that suddenly the settings seem to vanish or something, and my devices can no longer cast to the SA30. I then have go through the Home process again (equally frustrating, then from out of nowhere it appears). This has only happened 3 times fortunately, otherwise it would have gone straight back to the dealer. Perhaps it should as it is.

I used to have it wireless but have it wired now since quite a while, but it still just happened, and I’m waiting again for the SA30 to appear.

I have the latest firmware etc, I have not tried a system reset or net reset caused I’m not sure what they do.

Perhaps I should add that it shows up on my computer, and I can play (I’m guessing it’s not casting) from for example Spotify to the SA30, but I assume this is because they’re both wired to the same router.