Automatically turning on and off and google cast problem

Hello. Arcam worked perfectly first half year then due to router switch or update some stuff started to annoy:

  1. Network standby is turned on, and now amp used to turn on and later off without any intent from me (not using any other remotes at a time).
  2. Google cast works not from the first time. Usually i open spotify, then turn Living Room on (google cast name) and play some song. Spotify then shows that song is being played and that it is being played through Living Room, however, I do not hear anything. Then I switch back to Spotify through phone, then again connect to Living Room, and then everything’s ok. Exept that sometimes it stops. And I have to press Play or even connect to google cast again.

I think things came up right after I switched router from no name Tenda to TP-Link and then made new google cast user and network reset. Furthermore, looks like arcam has updated automatically when I turned it off from the electric switch. There was a message on display that it’s updating when I turned it on, however, it updated and updated and updated for a very long time, so I just turned it off.

It shows now that I am using 1542 and 1.72. Maybe I have to update it manually via usb? Maybe somehow update went wrong and now I am facing the outcome of it?

Thanks in advance.

did you put the amp into your google home app again?

You can disable the network stand-by setting through the menu in the console panel. The default value will put the SA30 into stand-by after 20 minutes.

Yeah, but I want to use stand-by function. It’s very convenient. However, I do not want the amp starting when it wants to.

yes, i did. i made it maybe 4 different times (when router changed, when something with internet went wrong, when i was searching the problem why it didn’t work - it was a bit detached antennas).

previously after putting the amp into my google home everything worked just fine.

I have silimar problem, latest firmware, net standby off. SA30 randomly turns off after 5-20 min of playing via Chromecast (not UPNP, or Tidal Connect). Reset did not help. :confused: Some firmwares ago I did not observe such a problem. They seem not to be able to relase a fully working firmware…

… the problem seems not to occur when SA30 is connected to a home network using WiFi, but by ethernet cable. Strange.

Edit: restarts occur also when connected wireless.

Hi, MacP.

I use wifi 2.4 ghz. Didn’t try another methods. I suppose result will be the same.

Have manually reinstalled the system via usb. Have some doubts if it installed correctly cause it lasted around minute. However, system info shows that newest system is installed.

I wrote to support this evening. Maybe they will find some answer.

1 Like

I decided not to use a built-in chromecast (I still have the separate one by Google), and restarts does not occur. Hope next firmware update will solve this annoying problem (but I’m pretty sure it will introduce another one :crazy_face: )