SA30 not booting / firmware not properly loading

My SA30 seems to be defective since yesterday.

After powering on, it took > 30 seconds to boot up and then I got a prompt in the display „Press MENU for Options“. Except a basic menu nothing works.

What irritates me, the device no longer knows its serial number: „Serial Number Not Available” also MAC address is 000000…
Is the Firmware broken?

I have done nothing unusual, that could have caused it. I know, every IT user says that. :wink: Firmware is/was V867.

At first I performed a system reset in the menu. Same problem occurs.

Then I tried to install the latest firmware via USB through the menu. Since “Net Updating” did not disappear for over 30 minutes (!) on the display, I have now turned off the SA30.

I read in this forum that you can re-flash the firmware by pressing the Service button on the back while powering on with inserted USB stick. I have not tried it yet, cause I don’t want to make things worth - if this is at all possible.

Do I have to copy the latest swu file on the stick? It’s already on it. USB stick is formatted in FAT32.

I just emailed the Arcam support. But due to the holidays I will not hear anything back till next week.

Any help is highly appreciated. Thanks in advance.

1 Like

7 posts were merged into an existing topic: Weird user guidance during OTA firmware upgrade