Weird user guidance during OTA firmware upgrade

Thanks. Symptoms are the same. And at least I know what “Press menu for options” means.

But I did not perform an update when this happend. Maybe there is something else. OTA Update will not start automatically (I hope). At least it never did before.

OTA update will start automatically after the SA30 is switched on and a newer firmware is available. Some users reported OTA will commence even if it is disabled in the settings menu. There is a workaround to block these updates.

Ok. Than I probably must have interrupted to OTA Update yesterday and now I’m stuck in the recovery mode “Press menu for options”. :cry:

I’m afraid you’re right. Sorry I cannot give you any solid advice, I do not want to point you in the wrong direction. I think you have to wait for a response from Aram.

I had the same experience yesterday. After pressing menu on the sa30 I was able to do a NET reset in the system settings menu. Shortly after that it showed Update completed.
Then I did a system reset which took about 10 mins to complete.
As for now everything seems to work, except from the fact that it sometimes stops playing and switches to CD input. That’s a new one since v1027. The good news is that HiRes files play without distortion now, finally!

I moved the conversation from SA30 not booting / firmware not properly loading into this topic since it looks the same issue.

Update kicked off automatically when I turned the amp on today, then went to a screen that said press menu for options. Still on old 1.42 and net v0. No IP and cannot select any input. Tried updating using USB and now it is just sitting on the Net Updating screen. Has been like this for over 2 hours. Any suggestions?

It actually was waiting when I woke up this morning. The update took more than 3 hours to get off the Net Updating screen… Weird. Haven’t checked the version that took yet and I’m scared to leave OTA updating on now. Should I be scared?

I asked Arcam about this a while back.

1 Like

Today my SA30 updated automatically too. I experience similar behaviour, I elaborated on it in the following topic.

1 Like

Hello ijanric,
If the Net is reporting as v0. it may be that the Net module is stuck in recovery mode. Firstly try resetting the System and Net from the SA30’s menu. Although no IP is shown in the menu can you find it on your network? Try connecting it via Ethernet if not already, then see if it shows in your router or use a network sniffer to find the IP.
If you can find it on your network use the IP in a web browser and try loading the Web GUI. If you get to this point what are you presented with?

  1. If you see the normal web GUI try resetting the Net module via going to “Device Settings” tab then “Factory Reset”.

  2. If you are presented with a page titled “Software Update” you can try selecting the latest image.swu file (downloadable from [Arcam - SA30 - Class G Intelligent Integrated Amplifier] ).

If this fails, or you can not see the SA30 on your network, please contact your dealer to report the issue and it can then be booked in with one of our service centres dependant on your location.


This is exactly what happened @jvs1
I left it and it sorted itself out. Now listening to lovely music again and life is good! Glad I found this forum though for other SA30 users/lovers! :+1:


Thanks, @ARCAM_CS-Tom
It seems this update just hangs for a while and displays Net version 0 and no IP address. After leaving it updating over night, my son came to wake me up this morning telling it worked. Thanks for the really detailed instructions! Very cool community I’ve discovered here it seems! :raised_hands:

1 Like

I turned OTA updates off months ago and it’s done 2 or 3 since. So looks like disabling that feature actually does nothing. I’ve had Net updating stuck before so I usually turn it off and on again. This latest update appears to have gone okay so far. Using only in PM mode since update.

Hi Dirk,

I found an instruction from Arcam how to resolve / asses it in another topic, I moved all related topics into this thread. Please refer to Weird user guidance during OTA firmware upgrade - #16 by ARCAM_CS-Tom

Thanks. First I tried to reset Net settings. But once I check „Continue“ the SA30 ist Frozen and no key is responding. Same happened with USB Update yesterday.

I will hook it up to my router via cable and see what this brings.

I can access the Software Update and Recovery Page of the SA30. So far so good.
Once I upload the latest swu file I geht the following error:

[download_from_url] : Connection with server interrupted, try RESUME after 0
[network_thread] : Incoming network request: processing…
[download_from_url] : Connection with server interrupted, try RESUME after 0
[scan_ubi_volumes] : mtd7: Volume found : nsdk-settings
[scan_ubi_volumes] : mtd7: Volume found : nsdk-rootfs
[download_from_url] : Connection with server interrupted, try RESUME after 0
[download_from_url] : Image download started : ubi://ubi0:nsdk-rootfs/swupdate
[download_from_url] : download from url started : ubi://ubi0:nsdk-rootfs/swupdate
Software Update started !

File information: image.swu size: 135249408 bytes

As I heard nothin back from the Aracm Support for over a week and the tip of my dealer did not work either, I gave the tip with the “Service”-Button from this forum a shot.

During powering on, I pressed the “Service” button on the back of the device for about 60s with inserted USB stick with current SWU firmware image. The SA30 then took a long time to boot (different slower animation pattern in the display) and then after a few minutes came “Update completed Restarting”.

Et voilà the SA30 works again as usual :grinning::grinning::grinning:.
Interestingly, even the DIRAC curves were still “there” after the procedure. They used to be gone after every update.

Thanks. Great forum!


Hi guys,

I have an issue with my brand new SA30 running with firmware build 1027 v1.62.

After switching the unit on, it displays the “press menu for options message”.

The point is I can neither perform a net reset (the unit freezes) nor a usb upgrade (net is “updating” for almost 4 hours without success)so I am stuck with my brand new high end SA30.

Here are some informations displayed :

name: empty
serial number: empty

Additionnal information:
My device is not shown on my network although it’s connected with ethernet, so I can’t run any update using the network.
My usb key worked yesterday on the SA30 for playing music. I just cleaned it and used the Arcam website’s firmware file.

Hi Johnduff, welcome to the forum!

It looks like you’re facing the next issue Weird user guidance during OTA firmware upgrade

I know from the SA30 build 1108, version 1.66 release note (currently an old beta build) a fix exists:

## Changes from 1.62/1027

Fix list:
4090 – Disable “Press MENU for options” prompt when upgrading

I’m unsure what you should do in your situation, maybe @arcam_paul is able to provide some advice.

1 Like

Thanks @jvs1

Yes that looks like a failed net update to me. We’re talking through options via PM.

1 Like