SA30 build 969, version 1.51 (beta)

I switched Direct on and off, Dirac on and off. Rebooted. Tried again. When engaging the Dirac Live filter with PVR input which is connected to my phono stage, it goes silent. I then switch off the Dirac filter and the music returns… I will try it again. I made a slight change to the filter and reloaded it in the same slot and it overwrote it fine. I rebooted the SA 30. Again, total silence when engaging the Dirac filter. Setting Dirac to “no curve” the music returns. Music plays in Direct mode as well of course. Hmm, what should I do next? Reset the system?


Hello everyone,
First of all, thanks for involving us in this beta release testing.


My main media consumption and source of Audio (95%) is from the TV (the amplifier is not connected to any other source than HDMI, over which I get IPTV, Plex & Spotify). The 5 remaining % is some Chromecast. I have the Arcam Control APP installed on my iPhone running the latest version of iOS (14.4).

Installation and amplifier settings:

I absolutely want to keep TV POWER & TV VOLUME on Auto as the amplifier is in another room than my TV: in my living room, I have only the TV Q95T and my Dali speakers. Both Samsung One Connect Box and the SA30 are in a technical room, with my media server. Using the SA30 remote is therefore not an option for me.

TV AUDIO is on OFF (as I thought than powering off the ARC module was maybe the cause of the “ARC - No sound after standby” issue).

My main concerns are regarding ARC.

1) ARC - No sound after standby

My first frustration with the SA30 comes from the fact that after standby there is no sound (even if I power on the amplifier with the Arcam App).
The situation with this firmware is not resolved, but it is now easier to have sound.

Here you are my steps to have sound:
1.1 Turn on the TV. The sound is naturally on “TV Speakers” as the amplifier is still on standby
The amplifier logically does not appear in the list of “Sound outputs” on the TV

1.2 Turn on the amplifier with the Arcam APP

1.3 Wait for around 45 seconds, without doing anything more

1.4 The TV sound will then automatically switch to Amplifier BUT the app will show the message “Socket closed by remote peer” (see 4 — ImgBB)

!!! At this moment, the amplifier can be controlled by the TV remote, but the APP does not work anymore. To have the app working again, I must close it and relaunch it. After that, the Arcam Control app works as expected.

What has changed? Before the v969, to get sound from the amplifier I had to press on the source button in the Arcam remote APP several times, and click on “BD” before the “socket closed by remote peer” message appears and I have finally sound (waiting these 45 seconds was not doing anything)

2) ARC - Sound drops:
I understand from the release note that this issue is known and being investigated for a future firmware revision.

3) ARC - Not powering on the amplifier:
I understand from the release note that this issue is known and being investigated for a future firmware revision.

Hope it will help,

1 Like

I’ve installed the update via usb. There were a few strange consequences, in particular the SA30 kept coming on from standby in AUX mode, although it didn’t go into standby in this mode.
Another strange point is that every key press from the SA30 remote as I was resetting preferences such as max volumes triggered station changes on my Arcam tuner that’s sitting underneath. I will have to see if this persists.
I thought for a moment that the upgrade had cured a problem from the last upgrade, which is that the SA30 goes through the whole routine when coming out of standby, even when net standby is set to on. Unfortunately this still happens.
Also I have another quirk which is that any remote in the room brings the SA30 out of standby - this hasn’t been cured either. I’ve tried changing the system code from 16 to 19, but then the SA30 remote would do nothing and I can’t see how to set its code to 19.
However, listening to music is the main aim, and this starts tonight!

Do you by any chance use Home Assistant?

Had exactly this issue, and it was caused by using Home Assistant integration for Arcam FMJ AVR’S. Removing this integration from HA fixed the issue.
This issue appeared first in 867. Prior to that integration was working fine.

Well I have lost all Dirac with 969. I have reset the net and system and reloaded my filter into a different slot. No Dirac on analog inputs. And switching it on with Roon, causes Roon to lose lock and then cannot play any more music, saying error, lost contact with Arcam SA 30 etc. I am going to load 867 and hopefully restore Dirac.

Good news, the distortion bug seems to be gone…

Well I am happy to report that I downgraded back to 867 and all is fine again. Dirac works again. I am willing to try 969 again after the engineers figure out what is wrong with Dirac with Roon. I was excited about the performance with Roon until the Dirac bug hit. The distortion bug seemed to be gone and I thought the sound was spectacular. But losing Dirac on my analog inputs freaked me out. Also, when loading 969, the SA 30 did not show the status bars under Net Updating like it does when loading 867. I can try reloading 969 later after I get some feedback.



1 Like

No, haven’t used Home Assistant. It was definitely 867 that introduced it.

Another bug between 969 and MusicLife 2.3.6 (895) (Android).

  1. When playing music went to “Playing now”
  2. Tried to set volume using volume buttons on that screen. Volume was changing on app screen, but not in amp. No reaction of amp whatsoever.
  3. Have opened remote section of the MusicLife app, it seemed to have re-established connection to SA30 and volume got crazy. It seemed like if app would buffer all of my key-presses for volume control on another screen, and started increasnig and decreasing volume on it’s own, with me “fighting” with it using knob. At one point app showed me volume 57 (i have max volume set to 40), fortunately blocked by amp’s limitation to 40. After this volume scaling was again messed up (it showed 57 instead of 40, which should be the max…).
    So at least one major bug (Dirac issues), and 2 minor bugs for me in this version.
    Also it’s very unstable (random reboots i.e. when starting FLAC playback from MusicLife, same file played correctly after the reboot), but hard to say which reboots are a bugs, and which are… debugging.
    I’ll probably try to play a bit more, and downgrade back to 867 tomorrow.

Hmmm, for me it did show the progress bar.

@derekc23 ok, and no other home automation system, or anything that would try to use IP or RS232 control protocols?

That is interesting…Maybe I should try to reload it again. I have some time later today.I will redownload 969 too. With Dirac totally not working on my SA 30 I was afraid something bad had happened, I have never seen my SA30 just pause and reboot itself like that.

I did, but it was caused by this IP control from Home Assistant.
On this firmware however it just happens at random moments. I guess this is what @arcam_paul was referring to when saying about reboots caused by enabled debugging.

I want to help with the debugging. But this is the heart of my music system and I had lost too much functionality to continue with 969. But you seeing a progress bar and me not is telling me maybe something did not load properly…

You can try to re-flash, might help with some issues.
But dirac bug is still there, i albo have it (with roon at least).
I guess we have reported enough bugs for now.
BTW just had another reboot when waking amp from standby. This time without Home Assistant’s… assistance :slight_smile:
In current form it’s far too unstable too keep it on device for longer, than 1-2 days for Basic tests.

1 Like

No, nothing as far as I know.

I will try a reflash later, then not load Dirac filter. I want to further test to make sure the distortion bug is gone. It was making some beautiful music before it crashed. I was very excited.

Hello everyone,

Follow-up of my « ARC - No sound after standby » test report of yesterday:

Yesterday evening, I’ve reproduced the process a dozen of time (rebooting, switching off then on the TV or waking it from standby) and the described behaviour was consistent across all tests.

Hi all

Thanks for the early feedback. I’m finding it a little difficult to track the reports in this thread, so forgive me if I’ve missed anyone out of the replies.

This is good feedback, and something we can look at.

Slow encoder is typically due to debug logging, but we can double check that.

In my testing, I’ve found if you have Net Standby disabled, it can take a while to reconnect to ARC. If you have Net Standby Active, then it should make reconnecting to ARC much quicker as it doesn’t have to do a full boot each time.

“Socket closed by remote peer” implies the SA30 is closing the socket connection, but I’m not sure why it would do this. I’ll have a look into this. Do you have any other home automation software that connects via IP to the SA30?

Looking at our issue tracker, this behaviour was fixed I think before the last public release. It may be theres a specific remote that still interferes. Can you give us information about what remote control this is, and what the manufacturer is? Do you have Net Standby active or disabled?

I’m unable to reproduce this with a Samsung TV remote (the only other one in my house).

I can try and reproduce this today. In my experience, almost all of the reboots are due to debug logging. If I turn debug logging off, then I no longer get the reboots, which is why future builds should ship with no debug logging enabled.

I still can’t get the HDMI ARC to work. I tried to follow the sequence from alex_otb. One thing that I noticed is that the Arcam APP (step 1.2), whether on iphone or ipad, won’t turn on the SA30 from standby. I guess that doesn’t matter as I bring it out of standby with the Remote control power switch. I did get the message in 1.4, but no sound from the SA30.
I do have the TV (LG OLED) connected to a SONOS soundbase via optical, but I’m assuming that this shouldn’t affect the issue.

The main remote is an LG OLED TV one. Any button on that seems to trigger the SA30. Net standby is on because that is what I was told would stop it going through the whole startup routine when coming out of standby. (But it doesn’t!!)

I suddenly remembered that I had set up the SA30 via Google Home on the Ipad, as this was needed for over the air update. Unfortunately, I can’t now remove it. Is there any clever way of doing this, as I’ve tried the usual remove device routine.

Do you have Net Standby active? If not everything shuts down in standby, including the network module.