Balance full over to the left channel when starting the SA30

Scenario
Perform the following steps:

  1. switch on Arcam SA30 version 0.100.1027.0x831c98a,
  2. play music

Actual result
Balance full over to the left channel. I can balance it through the remote but when I switch off “it forgets” the setting and powering on I return to #1 above.

That’s about it - its pretty annoying, but I couldn’t find anyone else reporting this issue on the forum. Any suggestions welcome.

Thanks in advance.

You should start by upgrading to latest firmware and performing full system and net reset.
Latest public release is 1206: https://www.arcam.co.uk/ugc/tor/SA30/Software%20V1206/SA30%20V1206%20V1.72.zip
I haven’t heard about anyone else having similar issue, but you can start from FW upgrade and reset. If issue is still there, contact Arcam support.

2 Likes

I have comparable issue. When I start playing stereo image is fine, after 30 mins I only have left channel left. Switch system to stand-by and on again will reset to stereo.
And then this only happens when playing on lower volume (15). When set higher (20) it plays fine for hours.
Hoped it would be better with 1306 beta but unfortunately not

Hmmm, strange issue. Might be a hardware issue.
What happens if you would increase the volume after right channel goes silent?

So flashed the SA30 with the latest f/w and it seems to gone from vaguely annoying to bad.

Followed the pdf instructions for updating the f/w, all seemed successful and went according to script, I had all the right numbers reported at the end of the procedure. All seemed good. However the remote control no longer works, and nor does the Roon End point. :sob:

Need to do a bit of research on the forum to see if I can recover this.

Any ideas welcome.

*** UPDATE ***
OK - disconnecting and reconnecting the power to the SA30 seems to have improved things. Its now resumed Roon Endpoint duties, but the remote is still not playing nicely.

Have you done full reset? System and Net, from the menu?
If after full reset you’re still having issue, check remote code in the menu (Menu->System Settings->System code). Should be 16 by default, if it’s anything else, change to 16 and check remote.

Hi,

Yeah I followed the pdf instructions including the System and Het reset. The remote code looks to be *16, which hopefully is correct because I’ve no idea how to change it from the from panel buttons.

But on the positive side - its looks as though the original balance issue has been resolved :wink:

If the remote doesn’t work. You have to push the ”AMP” button on the remote first… Have you tried that?

Right channel does not go quit entirely, but is considerably below what is should be.
Tested again this evening:
Played music at low level (14) until right channel dropped. Turned volume up to 30 after which right channel came back up again. After that turned volume down again (14). After this right channel remained functioning normally.

Hi @bvm,

Yeah thanks for the comment, but I yeah I tried that.

Ok, sounds like issue with power amp (hardware) rather than software. I would suggest contacting your dealership or local service center.
Not saying this is the cause here, but sometimes this kind of behavior points to a failed/failing transistor in differential couple of power amp. And usually you can “unclog” by turning up the volume, hence my question.
But again - i really don’t think it’s software related.

Maybe a stupid question, but have you tried replacing remote batteries? Some people had some strange issues with remote, and usually it was batteries. One provided by Arcam seem to be a lottery. For some they only lasted like couple of months, for me they work ok since over a year.

I saw some posts suggesting this may be the issue, it may have been one of yours actually :wink:

I haven’t tried batteries yet, but I try using the remote control from my AVR550, adding the SA30 to my Harmony, neither of these work. I’ll give the batteries a try though

I also saw something about the Arcam Home Assistant integration potentially causing folks issues. I go it this running, but happy to give that a shot too.

I’d actually rather control the amp via IP, are there any documented API’s of alike?

Ok, so it might not be batteries :slight_smile:
But good to check. If it doesn’t work, i suggest contacting Arcam support. It’s really strange, and i’m out of ideas…

I had some strange issues when using Home Assistant integration. It worked just fine at the beginning, but after one of the firmware upgraded it started to cause some issues. Amp started crashing and rebooting itself randomly. Issues gone after i removed the integration.
But have to admit, that i haven’t tried with latest firmwares. Might give it a go one more time.
IP control protocol documentation can be found on Arcam website.

Okay. Thanks for support and I will get in touch with dealer. It’s still under warranty so don’t expect any problems there.

Groet,

Take Osse

Thanks for all your help @Felix, if I figure it out I’ll update this thread, and maybe do a cartwheel :rofl:

Got the SA30 back today. They found corrosion on 2 speakerrelais. Have been replaced, machine has been playing faultlessly for last couple of hours. :grinning:

1 Like