SA30 build 705 version 1.33

Not sure if this is your problem, but check the SA30 is using the same IP address as where you are casting from - eg laptop or PC etc.

My router is in the living room, but my SA30 and windows 10 laptop are in my front room. So I have two WiFi extender discs in the front room to boost the signal from the router and enable the SA30 and laptop to connect to the network. I couldn’t cast the other day, and then I realised the SA30 was attached to one extender disc, and my laptop was attached to the other disc. Both discs have different IP addresses, so I connected the laptop to the same disc as the SA30 and bingo, was able to cast no problem. Hope this helps.

I find it very confusing that Arcam doesn’t mention the “lip sync” in the fix list.

Any way, the lip sync issues I experienced with an optical cable from my TV to the SA30 are mostly gone. I write “mostly”, because there is still a very small delay resulting in an echo when both the television and SA30 are playing. But when i mute the sound of my TV, the sound is synced enough with the visuals not to be bothered. So I can live with it. :slightly_smiling_face:

Very strange that the added “lip sync” menu only allows to delay the sound of the SA30 with 0-200ms and not to the reverse, which basically makes the problem just worse in my case :upside_down_face:

1 Like

Yes, wouldn’t it be great if the SA30 could play a sound before it arrived at the input? :stuck_out_tongue:

Yes indeed :innocent: the sound of the future!

Or… just make a “digital direct” option with zero delay would also be awesome :slightly_smiling_face:

Thanks for that. My laptop is on the same network as the SA30 and I can access the Web GUI On my laptop. If I right click a file on my laptop and Select cast to device Arcam SA30 is listed but when I Select it the SA30 recognises the file by displaying its meta data but then will refuse to play it. The cast to device app on Windows recognises the SA30 as well because it displays the Harman Kardon logo. If I do exactly the same things but select my Oppo player it will work ok. I have tried this same test on my PC with the same results. I have checked also that the Windows media sharing options are set to allow streaming to the SA30 which they are.

I can work around it anyway by putting the track onto my UPNP server Located on my NAS which shows up under My Computer and then selecting cast to device from there in which case i assume it is using the UPNP engine within that app on my NAS.

When I raised it initially some time ago someone said it didn’t work for them either.

1 Like

I was the one who faced the same problem, the problem is outlined in the issue below.

I reposted because gyrffe had said it worked when he/she tried it.

Sorry, I misunderstood your problem.

I mistakenly thought you could not cast from Google Chrome on a windows 10 machine. eg - cast music or dialogue to the SA30 from BBC Sounds, or iPlayer etc. I can do this, but like you I cannot play Flac files from NAS or hard drive.

Apologies for the confusion.

Hi Chris, welcome to the forum!

I can confirm I’m able to switch from NET input channel (listening to music played from NAS) to ARC input channel by using the remote:

  1. First I have to press on the “PC USB” button on the Arcam remote, Arcam console states ARC input channel is selected but no TV sound is played yet.
  2. Next I have to select tools button → receiver option on the Samsung TV remote in order to play TV sound through SA30.

I guess the second step is required to forward the TV audio from TV speaker to the receiver and is required on a Samsung TV only. Different TV brands might handle this differently.

In a previous SA30 firmware build discussion (this article has been unlisted) it was partly possible to switch to ARC input channel (remember @Mark’s pun: Icing on the ARCake :slight_smile: ).

FYI. I added a separate section to the starting topic with issues reported in this forum which are fixed in this build.

4 posts were merged into an existing topic: ARC: audio interruptions are noticeable, ref#92

Good to hear that the issue with sporadic distortion w analogue inputs seems to be solved, was quite annoying when playing cds- I have now connected my cd-player via dig coax instead. Sadly v705 has introduced other issues such as distortion on almost every MQA/hi-res track after a couple of hours of streaming…makes you wonder how much testing Arcam does before releasing their firmware updates…

I have an answer on the volume difference between firmware issues fromArcam.

The update fixed a bug where some inputs were too loud. All of the inputs have now been unified. The reason he can hear a change, is that 521 had filters set wrong from anything under 192khz… Like it gets progressively worse as you drop down, the bass gets over emphisized

1 Like

Interesting! Did he have any comments about the distortion that has come with v705?

No he asked me about it. I told him that in my case it was doing it after several hours of constant streaming of music from my NAS. I told him that all my music was in FLAC format at various resolutions from 44.1 to 192. It didn’t matter what sample rate but that the only way to resolve it was to power off and back on again. I told him that others on this forum have mentioned it did it with Tidal and MQA files as well and that it definitely doesn’t do it on V521 as I have been using that version for over a week now and not heard any distortion.

I saw now that I also got a response from Arcam support, and he says that the distortion-issue with MQA/hi-res tracks was detected by the software team as it was releasing (V705) and they are working on a fix for it…

Good to hear this is being fixed - it’s getting irritating.

Yes its very frustrating. They couldn’t say when the fix will be released though…Probably a good idea that everyone who experience distortion or other issues w 705 report this to Arcam support to maybe speed it up a bit…since v705 apparantly is regarded a mandatory update there is (according to the support) no other way to avoid the SA30 from updating than to disconnect the amp entirely from the internet…

Yes there is, DNS blocking or simply deny all internet access to the SA30. Refer to next topic.

1 Like

Good! Didn’t see that…just referred to my answer from Arcam…