SA30 build 1542 version 1.72

I don’t do any streaming so I will not be able to test that but I did notice a few more entries in the menus and everything I use it for seems to still be working.

A useful new option I found is to be able to set the balance in PVR mode. Previously that wasn’t available.

Hi Ken, i have the same experience i had the latest beta and after updating i figured some harsh tones in the highs. Wil try the system and net reset today.

1 Like

So now that Tidal Connect is supported I might sign up and give it a go. Is it just a case of logging into Tidal using the newly updated MusicLife app, finding music and playing it or do I need to do some configuration first?

Sign up in Tidal and use the Tidal app. In the ios app you tap on the bar on the bottom and from there you can select tidal connect to supported devices.

Does anyone in the thread have any CD connected to Arcam via Coax or Optical? If so - can you confirm after the update the music is being played from the beginning now?

I thought you used the Arcam MusicLife app as I got a notification it had been updated and I have updated the amp firmware.

You can use the MusicLife app, but that was already possible before the update. Tidal connect makes it possible to by-pass the Arcam app and use the Tidal app to stream music directly from Tidal to SA30. Which is way nicer because the Tidal app is designed to help you browse through music and discover new music, instead of MusicLife which doesnot suggest new music, or albums linked to what you are listening to.


Ok. I’ll give it a go. I think I’m getting confused by the term Tidal Connect because last year I tried one of their trials and I was able to play music from the MusicLife app to the SA30 so I’m sat here thinking what’s changed.

Mine started net upgrading yesterday. 24 hours later it still does… can’t use it, can’t reset it, power off does not help, net reset does not work (the ‘return’ button to confirm does not respond), resetting my router does not help, net settings are all empty (I can open the menu, sometimes)… what can I do to make the machine finish the net upgrade? I can’t pass the update either.

There is a factory reset procedure to follow. Arcam has never posted it. They want tech support to guide you. Give them a call. Sorry!!!


Okay… that will be interesting, me not being a native English speaker🤨. But thank you for your reply. I called my retailer, they are investigating what could be the problem as well. But did not call back yet.

For me this update is just terrible, can’t really make it work. I installed previous version and the install process was so easy, as it has been before. But this new firmware just never completes, hangs, or when it seems that it has completed, then network does not work properly and have to hard reboot. Have been dealing with problems this past 24 hours, tried everything, USB, OTA, Browser upload, System Reset, Network Reset… by the way Network Reset never completes.
I am attempting once more since I reverted back to the previous firmware, but something is wrong with this firmware. More info in my previous post

I dessisted, I am gonna stick with old firmware that is the only one I have in my laptop.
until I can find a newer version, but I suggest people skip this one
Since as many have said, it does not work on all devices.

Does anyone have a newer version that I can download? is there 1.70 or 1.71 available? Old links in this forum return 404

for me, this firmware fix also an eArc issue with my Samsung TV.
Now eARC work very well.

We are reading many question about issue but I think this firmware is a big step forward.
It miss simplier bass & tremble ajustement (than Dirac), renaming inputs and a new remote and it will be the most best amp.


Question to people, that have issues updating: what firmware are you on currently?
For example @andrescavallin seems to be on 1027, so old one. Have you tried to update to 1206 first, and go to 1542 from there?


I heard sound different between Tidal connect and Musiclife app.The same track from Tidal connect got less impact than Musiclife app.

Mine never wasn’t….CDS50 user

Do you mean yours was never connected by digital output or yours was never playing from the start?

Sorry,. Double negatives :rofl:

I mean I’ve never had the problem. I use a CDS50 connected via both analogue RCA and coax digital

When will audio delay issue be fixed with digital inputs??