SA30 build 1542 version 1.72

Today Arcam published a new firmware on their website.

Fix list

  • Add support for Tidal Connect
  • Add support for Spotify Connect
  • Add support for Amazon Music HD

Does anyone know if apart from the list above Arcam was fixing more?
Is the problem with DAC fixed where for music is not played from the beginning?

Update process took 10 minutes and restart took about 5 min.
Uploaded my Dirac curves and testing.
Is the high-frequency adc behaviour fix from net version 1306 included?
I think that changelog is too short :wink: only new features mentioned…

And whoa! New version of MusicLife app announced too!

The update came suddenly after a reboot. When the screen displays "update finished’
the amp didn’t reboot by itself. ( It should)
After 5 minutes i rebooted it myself.
Net it seemed to end in a bootloop.
Waiting for 10 minutes without change, i rebooted again. Then after 5 minutes suddenly the amp came to normal life again.

Strange behaviour during update process.

Easy peasy install. Took me like 10 minutes to have my SA30 and ST60 both updated and running again. Tidal Conect is working like a dream. Finally!

Just hope that they got the equivalent Qobuz connect somewhere on their to do list :slightly_smiling_face:……it’s never ending! :rofl:

1 Like

Qobuz doesn’t offer a “connect” interface.

Not doubting it may be different but I believe it is a thing article is a little old to be fair but I couldn’t immediately put my hand on newer although I recall having read it!

The Qobuz app itself refer to it as “Qobuz Connect”. in theory a UPnP renderer ought to appear there. I am not sure whether this is something Qobuz would have to enable or it’s something on the streamer/amp side. As the SA30 is a UPnP renderer, just like a host of other things on people’s home networks nowadays (like smart TVs), maybe this is something Qobuz just haven’t yet got sorted? Unsure. Still, you would hope that Harmon/Arcam and Qobuz would be talking about this as it would benefit both rather than the “lesser” casting options (chromecast and Airplay from Qobuz app)

…and let’s face it MusicLife is only a technical solution to stream, it’s not ever going to be able to replace or match up with the end user experience of browsing the Qobuz catalogue through their own app

I am unable to update from the web client. I click on 'Reboot device to the Update mode, I browse to the swu file on my laptop and it uploads it, states that it is updating and that my browser will refresh. The SA30 states NET updating but then after a couple of minutes it states update failed.

I have tried via USB and it fails as well. I’ve never had issues before updating.

you can use the interface in your browser

1 Like

Try net and system reset before upgrade.

Ok, despite the fact I got the message saying update failed it seems that was a red herring because after checking in system info I am told it has in fact updated. Very odd.

I have not reset the NET and System after the last couple of beta updates. But after updating to 1542 I thought the system sounded hard, more digital like with Roon and Tidal Connect. Maybe it was just in my head, but I went ahead and reset the NET and System, reloaded my Dirac filters and all sounds perfect again. Just curious if anyone else noticed anything after the update?



Did you unzip the file before loading?

Disregard my last comment, I didn’t read you were successful with the upload.

My SA30 showed NET UPDATING and I had to unplug the powercord after 20 minutes or so to get rid of this message. After that it showed that the update was completed.

I am glad you waited 20 min. The updating progress bar has not worked properly on my SA 30 for updates going back to last fall. I have learned to start the update and then go do something else so I am not tempted to reboot it before its done, thinking its stuck. It will show Net Updating for what seems like forever, then all of the sudden it powers off and reboots.


On mine (I posted about it yesterday) it sat there then came back saying update failed. I tried it 3 times and then on a whim thought to check the version number and it had actually updated!

Strange. So it’s working properly?