Occasional random reboots, ref#93

I rolled back to V521 as there are issues with the new firmware. Follow these instructions.

  1. Ensure that Web Client is configured prior to rolling back.
  2. Roll back the firmware.
  3. Do the SYSTEM reset after roll back but DO NOT do the NET reset as that will re initiate the Web Client.
  4. After doing the system reset go to settings / OTA UPG and set it to DISABLED.

If you can’t find a copy of V521 message me privately and I’ll send you a copy.

The reason I rolled back is because I preferred the louder more punchy sound on V521 and a couple of issues I found.

The amp will randomly reboot.
After several hours listening distortion begins to start without DIRAC.


I’m not sure if the downgrade will be complete and applied successfully because the release note of build 705 states various times (even in red and bold) that both the Net Reset and System Reset have to be applied.

Maybe there is another way to block the update? Perhaps block network traffic from SA30 to Arcam update site? In order to do this I would have to sniff the network traffic during an update, find out the ip addresses / urls and block them in your firewall or sinkhole them with pi-hole, etc.

Let’s just say I rolled back on Tuesday and it has been working perfectly since.

If you can live without the Web client then do the Net Reset.

It’s a bit odd though since I haven’t used the webclient, but the amp still somehow updated itself…(about a week or so after the v705 was released) with the automatic update function disabled;(

It can do it if the SA30 is connected to a Google Home network.

1 Like

In my case I did not have OTA auto updates enabled, it was my fault clicking the link to check for update not realising that I wouldn’t have the option then to say “no thanks”

Thanks! Good to know. My SA30 is set up with google home…

You were basically in the same situation as I was after rolling back and then doing the NET reset. This forces you to go through configuring the Web Client and as soon as it detects out of date firmware updates.

It’s annoying to be honest. Why can’t they have an option like most other pieces of kit with a message ‘There is a firmware upgrade would you like to upgrade yes or no

I have a reply from Ed at Arcam on a workaround to prevent accidental firmware updates if you choose to roll back.

Firstly, it would be worth knowing if a full host and net reset was carried out. If you reset the network component of the amp, then it will broadcast its own access point. Try connecting to this with a mobile device as your wifi access point. Type in the default IP address of the unit to access the web gui. When you connect it will try to perform this update check but as it has no internet connection, it will not succeed and should eventually time out and let you move on. Once you’ve gone that far, I believe that it does not check after this.