Unable to stream music or update software

Good evening all!

At the weekend I noticed that I was unable to stream music via airplay to my SA30, or connect the Arcam control app to the amp. Since I was mostly playing records I ignored the issue.

Tonight I have tried resetting the amplifier via the menu (Net). I tried to reconnect via Chromecast and Airplay, but when I started the process it did not work.

Then, I tried updating the software via the IP address, but was unable to connect.

I’ve had a look through previous posts on this forum and it seems likey that I will need to update via a USB stick? Is this correct?

Any help in resolving this would be much appreciated!

Version v1.72
Net Ver v1542
ARC Rx v1.0.0

I would reboot my modem then router, then reboot the Arcam and it might be sorted. Your Arcam will probably get a new IP address, so look through the system information on the Arcam and check the assigned IP address, then see if you can log into the SA 30 from a web page. Good Luck!


I tried all the above and have resolved the issue, fingers crossed. Many thanks!

1 Like