SA30 makes wheird stuttering sound version 1.72

Hey folks,

A few months ago I bought my ARCAM SA30. Until last week I was very satisfied with this great sounding amp. Since then, it started making wheird stuttering, repeating interruptions approximately once a day. The amp seems to get struck at one piece of the playing sound and repeats is at a very fast tempo in short time. It sounds like an razor…?

2 days ago I upgraded from v1.41 to 1.72 and this made it more worse. Now it is there every 30 minutes or so.

Does anyone recognizes this issue? Later on I will make a recording of the sound and upload it here.

Since I’m new i cannot upload directly so here is a link to the sound: Post info | SndUp

Thanks in advance!

Haven’t heard of such issue.
Have you made a full reset (net and system) after firmware upgrade?

Yes, I did it twice but no difference at all.

did you also try to unplug it from electricity and also unplug the router from the device(restart the router via unpluged) for more then 5 minutes.
i hade different problems and this solved it.
Sounds like connection problems.

Jaro

Hey Jaro, thanks for your answer. I tried this but doesn’t make a difference. It is also on analog inputs such as cd/aux so it is not connection related I think?

Hello Olivier, welcome to the forum!

Thanks for attaching the audio recording, it really helps in understanding the issue. I never heard this sound before. @arcam_mark could you have a look at this issue and maybe provide us with some directions how to troubleshoot this issue? Thank you.

Seems almost all things been checked.
I would try to re-flash firmware again (to rule out any issues with flashing, which happened in the past, at least with AVR’s), and if it doesn’t help, would contact local dealership or service center.

Woudl be really nice, thanks!

Thanks for your answer, where can I find older firmware versions so I can rule this out? Unfortunately I bought the amp second hand 6 months ago and I don’t have any invoices. So to get it checked by a dealer will cost me money :frowning:

Appreciate you are saying you didn’t have the issue before the upgrade but just wondering, how do you know this isn’t a problem with the source?

You mentioned CD analogue connection, do you have that in direct mode? Are you able to try the same source with another amp or another source on the same SA30 input? Have you tried the CD and listened ok on another device like in a computer?

Thanks for your information! The issue is on all sources, like: ARC, TIDAL direct, TIDAL via chromecast and CD. I testen CD to check if it is streaming related or not.

As mentioned try analogue direct form your CD or even play some vinyl if you have a record deck, or even old tapes. Assuming they are ok, sounds like the possibly ADC/DAC or even DSP related. If it were me I’d contact Arcam direct in you region for support and see what they have to say.

Today I tried this. Indeed in direct mode it is working seemless without issues. When turning it off, the issues are still there of course. This is a very pitty cause this may point to a hardware issue and I don’t have any warranty… Such a shame for such a top off the bill amp which costs a lot…

I will try to contact Arcam direct. Anyone other suggestions?

Try an engineer full reset as detailed in the link below.

If you have any DIRAC curves loaded make sure you have a backup of them somewhere as you will need to reload them.

I will try this later on. Thanks for your information!

Today I’ve downgraded to v1.2x which I found somewhere on the forum. Seems to play fine for a few hours now… Tested chromcast built-in. Tonight I will test ARC.

Device upgraded automatically after a few hours to V1.61. Everything still OK…

Tomorrow I will upgrade via engineer reset to v1.71 to check it out.

Ok, very interesting. Tried to upgrade to 1.72 (downloaded build 1306 via ARCAM website) via USB with engineer reset (service button at back) But couldn’t get it in upgrade mode. It just boots up and nothing happens.

After manual USB upgrade it stucks at ‘net updating’ for hours. After manual reboot it says: ‘press menu to continue’…

So I end up by upgrade it via web UI. Unfortunately again after a few minutes my issues is back again. So I downgraded to v1.61 now and it plays very well…

I think there must be a bug in this software. Anyone ideas?

Hmmm, now i see, that on Arcam website we still have 1206, so maybe that’s why it was not released?
Haven’t seen that issue, but i’m using Roon, which might make a difference.

@arcam_paul any input?

I wasn’t aware 1306 was ever put on the Arcam website. If it was it wasn’t up loaded for long. I thought it was just made available on this forum.

Well, it is RC. Also didn’t know, so checked now.
Since this RC didn’t make it as public, maybe there is some bug, and maybe that’s the one experienced by @Olivier ?