Remote Won't Enter Programming Mode

Just got my new SA30 and loving it so far. Only problem I have right now is with the remote.

I’m trying to program the remote to control my BD player but the button combination (Pressing BD + 1 for 3 seconds) is not working. After 3 seconds, the remote’s backlight just dims and starts flickering faintly but the LED does not stay on. I’ve tried other inputs and the same story. I’ve also tried to activate the learn function, but same result.

Is my remote faulty or am I missing a step?

Thank you!

BD button is locked, this is why you can’t make it to work!
You need to look a little down in the manual to understand how to unlock it first.
I tried that myself and ended up using the AV coax input which is unlocked and works without any additional steps.

The learning function for the AV is working perfectly for me but strangely I wasn’t able to make my Node detect the signal from the remote at all(the default AV commands). What I did is to program the Node with another old remote which I am no longer using, and then I made the Arcam’s remote to learn the commands from that other remote. This is now working perfectly.