MusicLife sources in Chinese language on Uk phone

Arcam SA30 1206 Firmware.
MusicLife 4.1.5 (4157)
iPhone 12 iOS 15

When I go into the sources for my MusicLife app they are in Chinese characters. The main app is in English it’s just the sources. I play tidal but other source like radio stations are also in Chinese.

I’m not on a vpn and my iPhone locale is British/English any ideas as the streaming side of the SA30 is useless

One thing I did notice is that when I access the SA30 web client the browser asks me if I want to translate from Chinese even though all the characters are English.

Any ideas?


I took a look into this and the most likely cause is something has changed the locale in your unit. A likely source could be Google Home? Are you using that? If so please check if it configuring the locale in a way you don’t expect.

Also, can you try this please, using your browser on the same network as the SA30:


Where <device_ip> is your SA30’s IP address (which MusicLife will display next to the selected device.

If that returns a language other then en_US something on your network has changed it (currently, no option on the unit or MusicLife can change it and the default from the factory is en_US). If you can’t find out what changed it I can help you set it to the correct value but ideally, it’d be best to find out what is changing it and set it up to the language you want but it is possible it will get changed again by whatever happens to be changing it.

The reason that only the sources are being shown in a different language is that the source names come from a third party service that is honouring the configured locale but the other text in MusicLife is configured by the phone language (currently only English and Japanese).

Please me me know how you get on. If that web request returns en_US then I’ll have to do a bit more digging.

Best regards

Hello ringtail, welcome to the forum! Thank you for your assistance.

@iapainter are you aware a new (4.1.5) Music Life iOS app has been released 2 weeks ago. The release notes state ‘added Japanese language support’ and some issues are fixed. Did you try this version?


I tried the steps you mention and I didn’t see the issue. I tested 4.1.6 which is in beta now and includes the Japanese update. Please let me know the results of the test I mentioned in my earlier post.

Best regards

(for clarity I am a Harman employee)


Yes it’s fixed. I did another net reset and it switched back to English. Not sure why it happened to be in Chinese in the first place. My SA30 was like that straight out of the box and after I’d updated to the latest firmware. Anyway it’s fixed now. The multiple net resets seem to have done the trick.

Many thanks for the response