Firmware updated to last version after I switched OTA auto update off

Hi, community.

I have sa30 for 2 years now. Previously i had no issues with a device, however last year I have a lot of issues with an amp. I have last software version, however sound disappearance and stuttering happening all the time (it happens from every 30 min to several hours).

I’m trying to downgrade firmware to previous versions where I didn’t had any issues. I know hot to do it and can successfully install any version of firmware.

The problem is that after I do

firmware downgrade > net reset > system reset > switch auto update off in settings…

…amp updates to last software version automatically in 1-2 days. Once again: auto-update is swithed off in settings :joy::joy::joy:.

As a last option I always can configure the firewall to forbid sa30 connecting to Harman server for update.

However before that I would like to ask the community: does someone had such a funny case? How it can happen that it updates while it is disabled in a settings?


Hello Nikee, welcome to the forum!

If I remember correctly then disabling the auto update feature doesn’t prevent the device from updating. Another way to block updates is configuring a dns block, refer to article below. Links at the bottom of the topic start might be relevant too.

I had the same experience too…

Switching off OTA works for me. However, note that if you have the SA30 setup in Google Home for casting, then that seems to force the SA30 to uodate.

If it’s an issue I’d rather setup an IP filter on my router (you can set the source and destination to block usually) than rely on some external service.