AVR 750 + Tidal

Hello, I’m new here and I have Arcam AVR 750 and I just download the MusicLife app and connect it to my AVR .
I have a Tidal Master account and want to stream tidal via my AVR.
But don’t know how to add tidal to the MusicLife app?

Thanks

I’m not so sure you can, doesn’t look like the AVR-750 has streaming capability.

I think it supports UPnP, so should work.

Am not sure if there are differences in how MusicLife app sees the devices, but i have “Tidal” listed on the main screen, and after tapping it i can log in to the service.
If you don’t have it, might be Arcam is not supporting it for AVR750.
You can also try 3rd party apps like mConnect. With this app you can stream Tidal to any UPnP device.

I tried this because I found this article

where they said that it supports AVR750

But when I install Arcam remove app it found AVR via IP address but when I go in , the controll button doesn’t works .
Do I have to configure anything on the AVR itself?

In manual, I found that UPnP support but I don’t have experience with this .

And this nConncet app I should install on mobile ? but then it will be stream via BT?

Yes, you need to install mConnect on your mobile. It will NOT use BT. UPnP is a protocol, that will allow you to control playback from your mobile, but streaming will be done directly from internet to your AVR750 over network. In this case mobile is only kind of remote, just like when using MusicLife.

Ok good , so it means that it will be in full MQA quality ?

So, I install mConnect app .
I login into tidal via mConnect and use PlayTo and connect to Arcam
So far so good
On Arcam is shown home DMR playing but show 0.0 kbps and on-screen on Arcam is shown NoData
but in the setup menu, I see that the input stream is 96 kHz

When I play local sound from my phone via mConnect on Arcam it works and I can play music.
So it seems to be an issue with the connection to Tidal ?
But When I try to play music from tidal it just show Please wait and no sound at all
And I tried even lower quality 16bit/ 44Khz FLAC not master one

When I play tidal via mConnect on phone speakers it works .

Do you think it could be a problem that I have mConnect Lite ?

On Google play are 3 versions:
1, Lite I currently install

2, mconnect Player – Google Cast & DLNA/UPnP

3, mconnect Player HD – Google Cast & DLNA/UPnP - but this is Tablet version

No, your AVR doesn’t support MQA, so no matter which app you will use, you will never get full MQA unfold. First unfold will be done by app, but nothing more - no full MQA quality.

To be honest i don’t know what might be the issue. I used to use mConnect and Tidal with my old Onkyo AVR from 2012 and it worked ok.
Wonder if UPnP implementation in AVR750 is messed up?

ok I understand no MQA, but it not play any quality
It should not be an issue that I have lite version ? It’s only about adverts and bookmarks etc .

And when I play from local files it works
So mostlikely it is issue with mConnect and Tidal

So the issue was the quality set to master of HiFi in Tidal
http://www.conversdigital.com/eng/product/product03.php
when I lower to High which is 320kbps it’s start play but the reason for tidal is Master quality so it seems I have sell my Arcam 750 or use blue sound node or some other streamer