I am having hard reset the SA30 when i go from NET to CD or BD INPUTS. Also, the receiver gets stuck frequently when i attempt switch inputs. I have a wired internet connection that is fairly stable. My software is 1.72. NET - 1542. I had to do a Network reset a few weeks back and re-connect my unit. Ever since then it seems like I am having issues frequently. I shouldn’t have to POWER the unit OFF when changing inputs. A soft reset does NOT remedy the problem.

Mike that is a strange one and not seen anything like that myself.
Could it be worth doing another network reset followed by another factory reset

Hello all,

I can confirm the issue, although it happens mainly by switching from airplay to tidal connect. Sound stops and I had to power off and on manually (standby doesnt solve the problem).

While on the same page, I just started using Qobuz via Chromecast - every few houra rhe connection gets lost (I am using wi fi with extremely strong signal). Had anyone such an issue?


It starts with streaming of any kind whether from Music Life app or Tidal Connect. The input selector literally ‘gets stuck’ from the both the remote and the SA30 face. A hard reset is only remedy.


I am experiencing the same with a brand new SA30 (dec '22) with latest software. Very annoying when having a party and different people want to play their songs. But also switching between sources from the same phone (like Tidal, Spotify, Apple Music) often leads to complete freeze, only to be solved by hard reset. Would love to have it solved because overall I a very happy with the device.