Arcam Control iOS app not working

Hi all,
Arcam Control App iOS version 2.10.0 , build 21001 is not working,
Searching for Arcam devices… for a long time. Cant find SA30.

Has anybody experienced this issue?


Have a nice weekend all.



Just tested on my side with success.
Stupid question but I suppose that you already :

  • restarted the app and phone
  • restarted the amplifier

Have a nice day,

Is the SA30 and the device running the app on the same network?

I reinstald the app twice on the iOS.

Restarted, did network reset, unpluged the SA30.

Arcam Control cant find the Amp. Not a big deal, i m just wondering, was working fine until a week or so.

Hi folks! This is related to updating to iOS 14.5. To cut a long story short, Apple now require you to manually request a special entitlement to allow multicast broadcasts for apps. We knew this was coming, but didn’t know when it would be mandatory, and of course Apple didn’t tell us that.

We use multicast networking in order to discover devices.

We’ve already gotten that entitlement for MusicLife, but we are currently awaiting it for Control. Once we’ve been given the entitlement, we have to issue a new update to the App Store.

In the meantime, you can control your amps through the embedded control within MusicLife 3.3.0.

A sort of related question. Is the iOS app supposed to be able to bring the SA30 out of standby? App works fine when the unit is already switched on but can’t find it when it has been put into standby from the app.

@JaroDro sorry for pinging you, but just to let you know we’ve updated the app this morning to fix this issue. If you update the app you should be able to control the amp again.

@LuckyLuke yes, you just need to enable Network Standby. MENU > Network Settings > Net Standby > On

I just tested that by using the app (I’m on IOS 14.4.2 ) to put the SA30 in standby, which worked. I then brought it out of standby which, as arcam_paul says, works. However the sound was completely distorted. I put the SA30 into standby by the remote and then out again and all is well.
Coincidence? I’ve just updated to the latest beta, and had DIRAC on.

Most probably, although haven’t tested latest beta.

Please keep discussion of beta behaviour to the beta thread.

If you want to report an issue, report it there and provide us as much information as you can (what input is in use, what sample rate, etc) and we can look into it.

Thx again arcam_paul. That worked perfectly for me. Simple solution. Next time I’ll try and read the manual… :slight_smile:

1 Like