USB browsing SA30 and MusicLife

There are some miscommunications about USB browsing on the SA30 and the usage of USB in MusicLife app in the following posts:

  1. USB input for music playback on the SA30 is only available by using theWebClient, ref#67
  2. Non feature stated in SA30 manual, ref#71

This post should address these miscommunications. The first post stated the following and the second post is a result of the first:

‘There are no plans to bring USB browsing to SA30.’

This was an error. It turns out USB browsing via the front panel and IR remote is planned, but currently it is impossible to give specific time frames.

Browsing through the web client will be the best flow for this, as it is possible to show many more items at once. The two-line front panel display limits to only show two items at a time, which makes navigating large collections awkward.

Some additional clarifications on the following:

There are no plans to bring playing music from USB to MusicLife app and the SA30 remote control

The network code currently has no exposed methods for MusicLife to browse attached USB drives. Even if it did, there would be no way to provide rich metadata (album title, artist title, album artwork etc) from within MusicLife which is at odds with the other methods of browsing.

1 Like

I can no longer access music from either of my two USB hard drives via the WebClient. I haven’t used the USB drives to play music on the SA30 for a month or so, in that time there have been two software updates applied. Is this the reason I cannot access music on the hard drives now, or is there some setting I need to tweak?

I didn’t use the play from USB feature yet. But I can check. I’ll let you know the results later this evening.

I performed the following steps:

  1. SA30 is playing TV over ARC at the moment.
  2. Format USB with FAT32
  3. Copy folder with 2 .flac files to the USB. The USB contains one folder, in this folder there are two .flac files.
  4. Mount the USB stick in SA30
  5. Goto web client, usb

Actual result:
I don’t see the folder with .flac files, refer to screenshot below:

So I can confirm that I cannot see any files. However I didn’t use this functionality before. Is this the way to do it?

Thanks. Yes it is the USB socket that is underneath the Ethernet socket I was using, not the micro USB socket as my drive cannot connect to that because it does not have micro US cable. I wonder if it will work if I source a USB to Micro USB adapter and try to attach USB hard drive to micro USB socket?
ps - Did you realise that the micro USB socket is not actually shown in the manual :slight_smile: !!

I used the USB socket that is underneath the Ethernet socket, I’m not aware of any other micro USB socket neither in the manual not at the backside of the SA30.

Can you confirm If you performed the above steps with a previous build than the USB files would be visible in the web client?

Yes, if you check the back of the SA30 there is a micro USB socket, next to the RS232 socket. And if you look at the graphic that shows the rear of the SA30 in the online manual the micro USB socket is missing.

I am pretty certain I was able to play music from USB hard drive in a previous build.

I created an issue for it: Playing from USB not possible

Could you please have a look, correct it if necessary. Please also have a look at the build version. The latest builds are:

  • build_592_v1.24
  • build_623_v1.25.4
  • build_634_v1.27

After your confirmation I’ll create a ticket.


I have also asked the question over at AVForums thread on the SA30. Perhaps you would like to wait until somebody replies to me over there? I will let you know soon hopefully.

No problem, I’ll wait.

1 Like

According to ARCAM the micro USB is only for maintenance purposes and not for USB playback.

Thanks for info.

Have you used the other USB to play music?

Only with the official release software. Back then it worked but only over the Webinterface

Thanks, yes it only worked for me via Webinterface too.
One of the guys over at AVForums has confirmed he can play via USB as well. He hasn’t applied any of the Beta releases though, so seems safe to assume the subsequent builds have taken the USB playback facility away.

I tested several SA30 firmware versions, it got broken somewhere after build 521 version 1.21 (this is the current released firmware on the Arcam website). I added this information to the post I created for it: Playing from USB not possible, ref#87. Soon I’ll create a ticket for it.

Thanks. It’s not a feature I use a lot but is handy to have,

Ok. I do not use USB for playback (only for upgrade). I use playback through DLNA.

Do we know when the next “official” Arcam build is scheduled to be available?

Unfortunately I do not know when the next firmware will be released to the public.

Builds between the latest released SA30 firmware versions:

  • v1.6 and v1.12 -> 80 builds
  • v1.12 and v1.21 -> 109 builds
  • v1.21 and the current beta (v1.27) 113 builds.

Based on this historical data I would say a release build is nearly due, somewhere at build 659. Anyway I don’t know the date, we have to wait :slight_smile:

1 Like

I submitted the ticket, as stated earlier the forum post is here: Playing from USB not possible, ref#87

1 Like