Album art not shown in MusicLife, ref#89

Perform the following steps:

  1. start Music Life iOS app version 3.0.4 (3041)
  2. set audio output to iPad
  3. choose music source, music, by album
  4. browse through album list
  5. select the album with album art, select play now, tab on the current playing track in the bottom
  6. select the album without album art, select play now, tab on the current playing track in the bottom

Actual result

  1. In step 5: album art is shown
  2. In step 6: no album art visible, current playing track shows previous album art

Expected result
Correct album art is shown.

Additional information
Refer to video below

Just wanted to add that I have strictly no cover displayed whereas you seem to have sometimes a cover ans sometimes not.

Another information I need to add , on the SA30 I run build 590 , ver 1.24 that I obtained as Beta directly from ARCAM support about 4 weeks ago.
Could you please indicate the current official version that one get when downloading from ARCAM site ?
Would you think if I go for the most recent beta my cover issue could be partially solved and behave like by you (displaying some cover and sometimes not)

Thank you,

I added this to the issue.

Currently SA30 firmware build 521 version 1.21 is released at their website:

Probably not. The version of the SA30 firmware has nothing to do with this issue because this issue is related to visualizing album art. This information does not originate from the SA30. Besides this issue also occurs when playing music from your iPad (no SA30 is involved).

I think the cause why your app behaves different compared to mine is the source of the media is different. I use Plex Media Server to publish music through DLNA. You use probably different software.

As long as the cause of this issue in unclear we don’t know why the album art is not displayed. Once I had an issue caused by Plex, it published the wrong information. It is too soon to say this issue is caused by the DLNA software running on your NAS. I created a ticket for this issue, all we can do is wait. I think the issue contains enough information for now :wink:

Great I fully understand your analyse. I do work in software development as well… but I must admit thatI’m not necessarly that familiar with that technology , so I’m alway happy to learn from expert like you.
Just wanted to bring as many bricks as possible. sometimes the smallest detail can be the root couse.
thank you.

1 Like

I am using version 3.0.4 (3041) and am Not able to replicate. All my graphics are ok. I stream from my NAS using MinimServer.

Thank you for the additional information. Hi @hoffmap7 what software and version are you using on your NAS?

I have a Synology NAS and use MinimServer which is a free open source UPNP media server. I don’t know the versions but I’ve never had the issue described.

All my files are flac and I tag all my music files using Mp3tag.

OK , I found the problem. I had to activate the option on my multimedia server.
I apologize for that, and thank you for your support

No apologies necessary. You’re welcome. I’ll remove the reference to your issue from the starting topic.

Issue is postponed:

My configuration is different:

  • iPad iOS 12.4.5
  • Plex Media Server v1.18.3.2129

I think the bug is related to media tags icw the plex version I used. My plex is rather old and I cannot upgrade at the moment. Maybe postpone this issue after I have upgraded and retested it the the latest plex.